Workflow Connectivity Test Indicates Service Bus Timeout

Description of Issue

When testing the connectivity of workflow, you may get a small error stating that the RequestDiagnostic failed. Timeout trying to connect to Service Bus. 

Context
  • Workflow

  • Tyler Workflow

  • ExecuTime

  • Service Bus

  • vHosts

  • RabbitMQ

  • Workflow Dashboard

Cause

This issue is caused by excess data files from the RabbitMQ vhosts (virtual hosts). These excessive data files will cause the Workflow Service Bus service to not see Tyler Workflow. This can be verified by connecting to the Tyler Workflow Dashboard.

Resolution

Reboot the server that Workflow is installed on.

If that does not resolve the issue, the vhosts will need to be cleared. Please contact Time & Attendance Support or log a case via the Online Support Client Portal and reference this article.

Additional Information

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