There are unprocessed mail items in this batch

Description of Issue

When attempting to close a particularly large mail batch in Cashiering, an error states: Failed to finalize settlement because of the following error(s), check the log viewer for additional information: One batch could not be closed. There are unprocessed mail items in this batch. 

The batch is unable to close. 

Context
  • Cashiering

  • Mail Mode

  • Batch

  • Enterprise ERP

  • Munis

Cause

A bug causes the check image order to fall out of sync with the receipt order. 

Resolution

Upgrade to Cashiering 2024.2, which contains a fix for this issue. 


In the meantime for the affected batch, check the corresponding batch in Enterprise ERP (Munis). If totals match what is listed in Cashiering, Output/Release the batch in EERP. 

Contact Cashiering Support for assistance with manually closing the affected batch from the Cashiering database. 

Additional Information