Employee Access - failed to retrieve authentication token from identity provider 401 unauthorized



Description of Issue

Employee Access presents error:

Oops, something went wrong!

An internal error occurred. We suggest you pull over and contact your system administrator



Context
  • TID-W

  • Employee Access

  • EERP

  • Munis



Cause

Incorrect secret in the EA ERP Configuration



Resolution

Please create a case with TSM for assistance in the Support Portal



Additional Information
  1. Request Okta admin rights to tenant

  2. Login to https://tyler-<customeridentifier>-admin.okta.com

  3. Navigate to Applications>Applicatioins

  4. Search for erp-munis-clientcredentials of the affected environment

  5. Copy Client ID and Client Secret 

  6. Login as an Employee Access admin to https://<customeridentifier>.tylerportico.com/tess/admin/erp-config

  7. Test connection will show an error failed to retrieve authentication token from identity provider 401 unauthorized

  8. Click Edit

  9. Update with correct client secret, 3 times

  10. Save

  11. Login to Employee Access again https://<customeridentifier>.tylerportico.com/tesp/employee-selfservice/register