Payment Entry Unable to Email Receipts to Enterprise Forms

Description of Issue

When using Enterprise Forms to email Payment Entry Receipts to the Customer, an error occurs:

  • Email option CustomerEmailAddress is empty.

Context
  • Accounts Receivable

  • General Billing

  • Payment Entry

  • Print Invoices

  • Print Invoice Statements

  • ReadyForms

  • Enterprise Forms

  • Customers

  • Email

Cause

Enterprise Form Definition is setup to Force Email, and the Customer has no emails.

Resolution

Development is currently researching the issue. 

No current workaround at this time. Contact the appropriate Enterprise ERP Support team, based on billing category, for further assistance. See the following article: How to determine the correct Accounts Receivable support team to assist with an issue

Additional Information