Apostrophe in Pay code description results in blank Timeblocks section on Shift maintenance

Description of Issue

When attempting to change a timeblock on the Advanced Scheduling on the Shift Maintenance, the row for timeblock is missing.

Context
  • ExecuTime

  • Time & Attendance

  • Advanced Scheduling

  • Time Block

Cause

If pay code has an apostrophe present, it will not load the timeblock section of Shift Maintenance 

Resolution

In order to be able to see the timeblock area on the shift maintenance, all apostrophe's will need to be removed from the pay code descriptions:

Navigate to System Admin

Select Master File Management

Select Pay Codes

Review all pay codes or Ctrl + F to find ' in the search (apostrophe)

Click the pencil icon on the pay code in question and remove the apostrophe 

Click Save

Additional Information

Please reach out to Support in order to be notified once this has been addressed by Development in a future build. timeandattendance@tylertech.com