Tyler Integration Error Occured java.lang.NullPointerException
Description of Issue
We get Error Occured: java.lang.NullPointerException results on the Munis Scheduled Import Subscriptions
Context
- Executime
- Munis
- Organization Import
- Work Group Import
- Pay Code Import
- Employee Import
Cause
Server logging shows signs of WildFly service being unresponsive:
- 2022-02-25 07:30:08,836 WARN [net.executime.ui.controller.ConcurrentRequestHandler] (default task-32239) Continuing held concurrent request. Queue size: 1, Queue id: yLs9wXr93nFlHF-Fa_jtW9m8jiIsN6B2CiobakSS-/Index.do (637242715), Thread: default task-32243
- 2022-02-25 07:30:31,458 ERROR [net.executime.ui.controller.ExecuTimeRequestProcessor] (default task-32239) Error Processing Request.: java.lang.NullPointerException
Resolution
Tyler Hosted Executime clients please contact Tyler Seystems Management SaaS or Executime for assistance:
- Connect to the Executime Application server
- Restart the Executime service: How to restart the ExecuTime Service - OnPrem
- Once service is running again login to Executime as admin account
- With necessary permission start the Run Full Data Import Actions for each failed Full Run
- These are found in System Configuration → Tyler Integration → Actions
- Click on the button that resembles the Share symbol and click Only Run Job from the secondary pop up window
- Verify status of completed action in Full Run Completed Date Column, a green circle with a check mark symbol indicates success
Additional Information