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How to restart the ExecuTime Service - OnPrem
How to restart the ExecuTime Service - OnPrem
Description of Issue
How can I restart the Time and Attendance Service?
Context
- ExecuTime Application Server
- Time and Attendance
- Services
- Task Manager
Cause
Integration from Munis to Time and Attendance is not updating employee changes.
Resolution
Always schedule a time to restart the services with the client so their system is not unexpectedly unavailable during the restart.
From the ExecuTime App Server:
- Connect to TA App Server.
- This can be found on the Site Report for hosted clients or get connected with the site's IT person.
- To connect to a hosted clients app server
- Start a Remote Desktop Session from your computer
- Once logged in, Search for Remote Desktop
- In the Computer field, enter the Executime App Server name that you found on the Site Report
- Click the Start icon in the lower left.
- Find and click Services.
- Find and click the ExecuTime Prod service. (or Train, Text, Impl, etc)
- This might be named something different site to site.
- Click Stop this service to the left.
- Service Control box will pop up with progress bar. This will close on it's own once the service is finished stopping.
- Sometimes a Services box pops up with message, "Error: The service did not respond to the start of control request in a timely fashion."
- Click Ok to Services prompt.
- Open the Task Manager. (Regardless if you get the Services pop up box)
- Right click the bottom toolbar of the screen and click Task Manager.
Right click the column headers to show Command Line.
- Find the instance of JAVA with the command line value that matches the ET Prod (Train, Test, etc) Installation Directory.
- Example: Name = Java.exe, Command Line = e:/ET_Prod (Train, Test, etc)...
- Example: Name = OpenJDK Platform Binary, Command Line = e:/ET_Prod (Train, Test, etc)...
- If no instance of JAVA for your environment of ET is located, then no action is needed in task manager. If you do find an instance:
- Right click that JAVA line and select End Task.
- Task Manager box will pop up asking, Do you want to end java.exe? Click End Process.
- That line will now be removed from the Task Manager.
Go back into the Services program.
- Click the ExecuTime Prod service.
- Click Start the service to the left.
- This typically takes a few minutes to fully start back up.
- After allowing the system a few minutes to start back up, verify the services are back online by navigating to the ExecuTime login page.
Additional Information
SaaS clients: How to restart Executime Services - SaaS clients