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How to restart the ExecuTime Service - OnPrem

How to restart the ExecuTime Service - OnPrem

Description of Issue

How can I restart the Time and Attendance Service?

Context
  • ExecuTime Application Server
  • Time and Attendance
  • Services
  • Task Manager
Cause

Integration from Munis to Time and Attendance is not updating employee changes.

Resolution

Always schedule a time to restart the services with the client so their system is not unexpectedly unavailable during the restart.

From the ExecuTime App Server:

  1. Connect to TA App Server. 
    1. This can be found on the Site Report for hosted clients or get connected with the site's IT person.
    2. To connect to a hosted clients app server 
      1. Start a Remote Desktop Session from your computer
      2. Once logged in, Search for Remote Desktop
      3. In the Computer field, enter the Executime App Server name that you found on the Site Report
  2. Click the Start icon in the lower left.
  3. Find and click Services
  4. Find and click the ExecuTime Prod service. (or Train, Text, Impl, etc)
    1. This might be named something different site to site. 
  5. Click Stop this service to the left. 
    1. Service Control box will pop up with progress bar. This will close on it's own once the service is finished stopping.
  6. Sometimes a Services box pops up with message, "Error: The service did not respond to the start of control request in a timely fashion." 
    1. Click Ok to Services prompt. 
  7. Open the Task Manager. (Regardless if you get the Services pop up box)
    1. Right click the bottom toolbar of the screen and click Task Manager
  8. Right click the column headers to show Command Line. 

  9. Find the instance of JAVA with the command line value that matches the ET Prod (Train, Test, etc) Installation Directory.
    1. Example: Name = Java.exe, Command Line = e:/ET_Prod (Train, Test, etc)...
    2. Example: Name = OpenJDK Platform Binary, Command Line = e:/ET_Prod (Train, Test, etc)...
  10. If no instance of JAVA for your environment of ET is located, then no action is needed in task manager. If you do find an instance:
    1. Right click that JAVA line and select End Task.
    2. Task Manager box will pop up asking, Do you want to end java.exe? Click End Process
      1. That line will now be removed from the Task Manager. 

Go back into the Services program.

  1. Click the ExecuTime Prod service. 
  2. Click Start the service to the left. 
  3. This typically takes a few minutes to fully start back up. 
  4. After allowing the system a few minutes to start back up, verify the services are back online by navigating to the ExecuTime login page.
Additional Information