How to create an Administration account for the TCM Full Client

Description of Issue

How to create an Administration account for the TCM Full Client.

Context
  • CM

  • TCM

  • Content Manager

  • Tyler Content Manager

  • TCM Full Client application

  • EERP

  • Munis

  • Administration

Cause

A site Administrator should have an account ID within the CM Full Client that will allow them to perform administrator level functions such as setting passwords for users who log into the full client to complete Batch Scanning, or to use Document Search.
The id needs to be a separate, unique logon from the EERP ID as applying ADMINS to an existing ID used for other integration access may cause conflicts.

Resolution

In order to create an admin level ID within the full client a user will need to log into Content Manager with an ID that is applied to the ADMINS group. 

Please contact your site administrator to either provide you with an already existing administrative account to use or to configure a new administrative account. 
If your site administrator is not familiar with configuring an administrative account or is not aware of an already existing administrative account, please contact TSM or CM Support to further assist. 

Steps to create a new administrative account: 

  1. Log into CM Full Client that is already applied to ADMINS

  2. Administration tab

  3. Security Manager 

  4. Click Add Entry (Paper icon in the upper right-hand corner)

  5. Assign a User ID as well as a User Name

  6. Locate the Admins group in the Available Groups panel, then click the right arrow to add to the Selected Groups

  7. Click OK.

  8. Once the ID is created you will need to Edit the user and set the password.
    In older CM versions the message New user password is password. will display on the New User screen, but will be removed in CM versions 2023.1 and newer.
    Click the Edit User icon, then click the Change Password button to set a new password for that ID.
    The password must contain both numbers and letters.
    Check the User Reset Password Box, then click Change Password.

  9. User will need to login with the temporary password the first time logging in, and will prompted to change the password at that time.  

Additional Information

CAUTION: Adding an existing ID to ADMINS that is also applied to MUNISUSERS and MU_ groups may cause conflicts when accessing CM from Munis.
The standard practice is for site admins to have a separate ID applied to the ADMINS group only.  

For SaaS sites, users that are requesting administrative rights in the CM Full Client need to be listed on the SaaS Authorization page via the Cloud Admin (User Account Management > SaaS Authorization Form)

SaaS Sites: https://muniscloud.tylertech.com

AWS Sites: https://muniscloud.tylerhost.net

If the user is not listed on the SaaS Authorization page, they will need their site admin to update the SaaS Authorization page with their credentials. 

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