Change the Owner of Record Listed on a Bill
Description of Issue
The owner of record listed on a bill needs to be changed or updated.Â
Context
- Property Tax BillingÂ
- Bill Adjustments (txblgnmt)
Cause
The owner of record on a bill is incorrect.Â
Resolution
- Navigate to the Bill Adjustments program either by searching or using the following path:Â Property Revenues > Property Tax Billing > Region > State > Collection Processing > Bill Adjustments
- Click Search.Â
- On the next screen, click General.Â
- Enter the Bill number, AR category, and Year of the bill that needs to be changed.Â
- Click Accept.Â
- Click Owner of Record.Â
- Click Update.Â
- Enter the customer number of the correct owner of record.Â
- Click Accept.Â
Additional Information
- For guidance on adding a new customer, please follow the steps here: Add a New Customer
- For all resources related to owner maintenance on tax bills, please see: Change the Owner on a Tax Bill
- If further assistance is needed, please contact Tax Support for the appropriate region.Â