Change the Owner of Record Listed on a Bill

Description of Issue

The owner of record listed on a bill needs to be changed or updated. 

Context
  • Property Tax Billing 
  • Bill Adjustments (txblgnmt)
Cause

The owner of record on a bill is incorrect. 

Resolution
  1. Navigate to the Bill Adjustments program either by searching or using the following path: Property Revenues > Property Tax Billing > Region > State > Collection Processing > Bill Adjustments
  2. Click Search. 
  3. On the next screen, click General. 
  4. Enter the Bill number, AR category, and Year of the bill that needs to be changed. 
  5. Click Accept. 
  6. Click Owner of Record. 
  7. Click Update. 
  8. Enter the customer number of the correct owner of record. 
  9. Click Accept. 
Additional Information
  • For guidance on adding a new customer, please follow the steps here: Add a New Customer
  • For all resources related to owner maintenance on tax bills, please see: Change the Owner on a Tax Bill
  • If further assistance is needed, please contact Tax Support for the appropriate region.Â