How to limit access to Workflow Process Codes



Description of Issue

How to limit access so end users can only see/maintain certain Workflow process codes. 



Context

Workflow Business Rules

User Attributes 



Cause

Data access for workflow process views access and Workflow process maintenance access can be updated under Munis System Roles. This will restrict users' business rule access according to process codes. 



Resolution

To limit data access for workflow process views/workflow process maintenance:

Munis > System Administration > Security > Roles

  1. Search for the role you wish to update and click Accept

  2. Click Munis System (yellow folder)

  3. Scroll down to Data Access portion, and click Update

  4. Click the dropdown next to Workflow process views access and Workflow process maintenance access, and select None, Limited, or Full. Click Accept

    1. If you select Limited, Workflow Process View Access page will open.

    2. Here, click the three dots (...) to define which process codes should be accessible. Once all applicable have been selected, click Accept

    3. Click Back



Additional Information

Workflow Process Access restricts users' business rule access according to process codes. Specific program changes include:

  • In the Workflow Business Rules program, if the value of the Workflow Process Access list is None, the program displays a permissions error if you attempt to access process codes and you are not allowed to continue. If the permission is Full, you can maintain business rules for all process codes. If the access is Limited, you can only maintain those workflow process codes for which permissions are granted.

  • In Workflow User Attributes, when you demote a workflow approver or delete a workflow user, the program prompts you to move business rules and pending actions associated with that user to a new user. If you are restricted from maintaining any of the process codes on the rules assigned to the demoted or deleted user, then the program provides a permissions access message and directs you to work with your system administrator to complete the changes.

  • In Workflow Central, if you do not have workflow permissions (that is, the value of this list is None), you cannot access workflow process codes. If you have Limited permissions, you can access only those workflow process codes for which permission is granted. If you have Full permissions, you can access and maintain all workflow process codes.

Global business rules (rules with a blank process code in Workflow Business Rules) can only be maintained by users with Full access to workflow process codes. Also, process code data access restrictions only affect what you can find or maintain in Workflow Business Rules and Workflow Central or through certain actions in Workflow User Attributes. The Workflow Process Access restriction does not affect rules you may have as an approver or your access to pending actions generated from them.