TCM MU_ group showing as UNKNOWN

Description of Issue

When viewing a role's data access tab via the Roles program in Munis the MU_ security group it is linked to shows as *UNKNOWN*. This may also be causing a Server Connection Warning HTTP 401() error as well when users attempt to access TCM through Munis. 

Context
  • Munis

  • Enterprise ERP

  • Tyler Content Manager

  • CM

  • TCM

  • TCM Permissions 

Cause

The MU_ Group may be listed as *UNKNOWN* due to:

  • TylerCM Munis Users Group entry and/or the TylerCM Group Prefix in Content Manager for Munis Configuration screen is not entered correctly

  • The group is not yet existing in that corresponding TCM environment

  • It is a custom group created within the CM full client with an ID that is more than 20 characters long

  • The master password needs to be reset in the TylerCM for Munis Settings screen to refresh the connection between Munis and TCM

Resolution
  1. Log into EERP Hub > System Administreation > General Administration > TylerCM for Munis Settings

    1. The TylerCM Munis Users Group and TylerCM Group Prefix are case sensitive, and should be upper case 
      If either are lower or mixed case: 

      1. Click Edit

      2. Overwrite/update Entry(s)

      3. Click Accept

      4. Go to step 4.b

  2. Verify the MU_group exists in the corresponding TCM environment: 

    1. In that same Munis environment, navigate to Tyler Menu > System Administration > General Administration > TylerCM for Munis Settings

    2. Launch the first URL in a new tab

    3. Launch the TCM Full Client via Webstart (uses Java) or J-link (does not use Java)

    4. Login to the TCM Full Client with administrative rights 

    5. Administration > Security Manager > Groups > Verify if the MU_Group exists

  3. If the MU_ group exist ensure its Group ID is more than 20 characters 
    While TCM will allow more characters when creating a custom group, Munis limits the amount of characters to the Group ID to 20 

  4. If the MU_Group exists, navigate back to Munis to complete a master password reset:

    1. Tyler Menu > System Administration > General Administration > TylerCM for Munis Settings

    2. Select Master Password using the tcmadmin credentials found on site report 

    3. Select Rebuild TCM Caches 

    4. Navigate back to Roles to see if the MU_Group populates without error. If not, please contact TCM Support at +1 (800) 772-2260 ext 3807

  5.  If the MU_Group does not exist in the corresponding TCM Full Client: 

    1. Check to see if the group was created in one of the other CM environments and recreate it within the missing environment if that is the case

    2. If the group does not exist in any environment please contact TCM Support at +1 (800) 772-2260 ext 3807

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