A valid location code is required error when creating a Time Entry batch



Description of Issue

I have a new payroll user receiving an error when creating a Time Entry batch stating:

A valid location is required. (Loc restrictions may apply)

Context
  • Munis
  • Time Entry
  • Roles
Cause

Role that granted the user access to the payroll module did not have access to the location code that was entered on the Time Entry batch.

Resolution
  1. Access Roles: System Administration > Security > Roles
  2. Search on the role that grants the user access to payroll
  3. Click on the HR Management/Payroll folder
  4. Click into the yellow folder next to the Location maintenance access field
  5. Click the Update button, TAB into a new row and enter the desired location code in both From and To field
  6. Click Accept
Additional Information