Employee unable to make Life Event Election Changes


Description of Issue
  • We have an employee who is unable to make their Life Event Changes in ESS
  • When we access ESS → Benefits, we do not have the option to make elections
Context
  • Munis
  • Employee Self Services (ESS)
  • Life Event Enrollment
  • Benefits
Cause
  • Employees are unable to make Life Event selections until their Event Date from the Life Event has occurred
  • Employee has an existing Life Event record with a status of 1 - Submitted


Resolution
  • You must wait until the Life Event Event Date has passed before the Employee can make a Benefits Enrollment change
    1. To determine the Life Event's Event Date, navigate to the program Employee Life Event
      1. Located under Human Resources → Benefits Administration → Benefits Enrollment → Employee Life Event
    2. Review the field Event Date
  • The Life Event Enrollment record must be in the same benefit year as the current year
    1. To determine the current year, navigate to the program Benefit Enrollment Settings
      1. Located under Human Resources → Benefits Administration → Benefits Enrollment → Benefits Enrollment Setting
    2. Review the year and the dates associated with the fields for Current Year
  • Any preexisting Employee Life Event records must either be updated to status 2 - Approved or 3 - Closed or deleted
    1. Navigate to the program Employee Life Events
      1. Menu → Human Resources → Benefits Administration → Benefits Enrollment → Employee Life Events
    2. Select Search and define the impacted employee ID to review existing records
Additional Information