Cannot Post Recurring Invoice Batch With Inactive Customers

Description of Issue

Users can not post Recurring GB Invoice due to Inactive customers.

Batch Contains Invoice billed to Inactive Customers.

Inactive Customers
This batch contains invoices that are billed to inactive customers. Do you want to post them?

Context
  • Munis 2019.1 and up

  • General Billing

  • GB

  • Recurring Invoices

  • gbrecurr

  • Invoice Entry and Proof

  • gbinvent

Cause

Users will get this error either when a customer is inactive or when a customer has an inactive address.

Resolution

A System Administrator or IT member will need to adjust users permission to allow posting Invoices to inactive customers.

  1. Navigate to Tyler Menu System Administration > Security > User Attributes

  2. Click the Search button

  3. Enter User ID

  4. Click Accept

  5. Click the Roles tab 

  6. Click to highlight the role to be updated

  7. Click Edit Role 

  8. Click the General Billing folder

  9. Click Update

  10. Select the check box for Post invoices billed to inactive customers

  11. Click Accept 

Additional Information

Once the change is made, user will need to log out of Munis and log back in and post the batch. If user is unable to post batch, please log a case with Munis General Billing Support

Note that this permission will grant the user the ability to Browse inactive customers to determine which customer records are flagged inactive before making a determination as to whether the batch is ready to be posted

General Billing Invoice Entry and Proof Browse Inactive is blank

Verify That A Customer Is Active

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