Employee Import Error Cant update Deduction XXXX for Employee XXXX has wrong Start Date



Description of Issue

When trying to update the Start Date and End Date of an Employee Deduction using the Employee Import, the system is erroring out all lines.

Can't update. Deduction 'XXXX' for Employee #XXXX has wrong Start Date.



Context
  • Payroll

  • Employee Deductions

  • Employee Import



Cause

Each employee had two instances of the Deduction inside of Employee Deductions, so the system was unable to determine which instance they were trying to change information for.



Resolution

When processing an import to update Employee Deduction fields with multiple instances of the same deduction, the import file must specify which instance of the deduction code you are trying to update. 

This can best be accomplished by adding additional columns to the import file with information unique to the desired deduction.

Example: The Employee Number, Deduction Code and Pay Start date in the import file should match the existing record in Munis and the End Date can reference the change in the import to update the End Date. 



Additional Information