Import Error - Duplicating a Pay Where its End Date Comes Before the New Effective Date



Description of Issue

When importing new records into Employee Job/Salary and using the Use Automatic Pay Duplication option we are getting errors.

Duplicating a Pay Where its End Date Comes Before the New Effective Date



Context
  • Payroll

  • Employee Import

  • Employee Job/Salary



Cause

The pay record the user is attempting to import and duplicate has an end date that is prior to the new effective dated record.

The record that is being duplicated already has an effective end date (Pay End Date) and therefore can't be duplicated.



Resolution

If the employees are changing Job/Positions:

  1. Go to Employee Job/Salary (Payroll > Employee Maintenance > Employee Job/Salary)

    • Navigate to the employee's end dated record, click Add and a new record with a new effective date with the new Position/Job.

    • Or Process the import and do not use the Use Automatic Pay Duplication option. 

If the employees are staying in their current job/position: 

  1. Go to Employee Job/Salary (Payroll > Employee Maintenance > Employee Job/Salary)

  2. Search for the employee and pay. Click Update.

  3. Change the Pay End Date to 12/31/9999. Click Save. 

    1. This will update the effective end date to 12/31/9999.

  4. Then use the Duplicate option or import using the Use Automatic Pay Duplication option. 



Additional Information

The Use Automatic Pay Duplication in the Employee Import screen is for adding a new effective dated base pay record for the existing base pay. (Same Job/Position, etc.)

Effective Dated Pays and Positions