Pending Employee Job Salary base pay Duplicate is not duplicating associated pays



Description of Issue

When duplicating the base pay in Pending Employee Job/Salary, the additional pay codes are not duplicating. 



Context
  • Payroll

  • Human Resources

  • Personnel Actions

  • Pending Employee Job/Salary

  • Employee Job/Salary



Cause
  • Pays did not share the same effective date. 

  • The base pay was being end dated with a date prior to the new duplicate effective date. 



Resolution

If the End Date falls before the Effective Date of the new Base Pay record, this will cause the secondary pay records to not transfer over to the new Base Pay when trying to duplicate. Instead:

  1. From within Pending Employee Job/Salary.

  2. First select Duplicate on the base pay record. 

  3. Define the new effective date and other applicable information. Click Accept. 

    1. This will copy over the associated pays with the same effective date as the base pay. 

  4. Search for the prior effective dated record. 

  5. Click Update. Define the applicable End Date. Click Accept. 



Additional Information