Employee Pay Import errors - Cant import Job T201 does not match employees Job C210



Description of Issue

We have a few errors on the proof report when importing into Employee Job/Salary to update the Pay Status on some additional pay types. 

Can't import Job T201 does not match employee's Job C210



Context
  • Payroll

  • Employee Job/Salary

  • Employee Import



Cause

The non-base pay type being updated via the import had a different Job Class than the base pay. There was no base pay with the Job Class of the associated pay being changed. 



Resolution
  1. Go to Employee Job/Salary (Payroll>Employee Maintenance>Employee Job/Salary)

  2. Search for the employee and review their current pay records.

  3. Determine if the associated pay is linked to the incorrect Job Class or if there should be an existing base pay with the secondary Job Class. 

    1. If the associated pay is linked to the wrong Job Class. Delete the record then re-add it with the correct Job Class. 

    2. If the associated pay's Job Class should also have a base pay, click Add and add in the base pay associated with that Job Class. 



Additional Information

Example:

  • An employee's primary base pay is defined with Job Class C210.

  • The pay code being updated via the import has Job Class T201, but they do not have a base pay for that Job.

  • A secondary Job Class can not be added to an employee's Job/Salary record without first adding a base pay for that Job.

  • To test, try adding another pay code to the employee with Job T201. The error Missing base pay for this job would display. Which is why the error is showing on the import proof.