Cashiering Not Displaying in Hub Menu
Description of Issue
When opening the Tyler Menu in Hub, Cashiering is missing for all users
Context
- Hub
- Cashiering
Cause
The external system URL is not configured in Hub Administration
Resolution
- Log into Hub with an administrator account
- Click the cog wheel in the bottom left corner, then select Administration
- Under System Settings, expand External Systems
- Click Setup
- Look for Tyler Cashiering (or Cashiering) in the list and click the arrow to expand
- Enabled needs to be toggled on
- Enter the Application URL. This can be found in Tyler Deploy under Site Report
- Ex: https://xxxx.tylertech.com/train/cashiering/ui.web/
- Next to Endpoints, click Add twice to populate two variables
- First endpoint: Click dropdown and select Rest
- Base URL: Input https://FQDN/environment/cashiering/hub/
- Ex. https://xxxx.tylertech.com/train/cashiering/hub/
- Second endpoint: Click the dropdown and select OData
- Base URL: Input https://FQDN/environment/cashiering/hub/
- Ex. https://xxxx.tylertech.com/train/cashiering/hub/
- Click Save
- First endpoint: Click dropdown and select Rest
- Navigate back to the Hub home screen and reload the page. Cashiering should now display on the Tyler Menu
If the issue is not solved after taking these steps, please contact Tyler Systems Management (TSM) supportÂ
Additional Information
- If Cashiering shows on the menu but gives an error, log into the Cashiering application with the web URL to confirm user access
- After successfully logging into Tyler Cashiering, navigate back to Hub
- In the Tyler Menu, click the ellipses (three vertical dots) in the top right corner
- Click Refresh
If after following these steps Cashiering doesn't load in the menu, reference the following: Tyler Cashiering Not Accessible from Tyler Menu