Position Date not updating in Time and Attendance



Description of Issue

Employee Position dates not updating when running Time and Attendance Integration.



Context
  • Time and Attendance

  • v2020.x



Cause

When running the integration jobs 1 through 5, Employee's job (Time and Attendance Position) does not update dates and assign to new Position record. Employee in question is in the preview file for the integration but their newly assigned job record in Employee Job Salary does not load as part of the integration.

Employee Mapping Table has update Position records turned on.  Not running integration job 12 (Employee Position Integration)



Resolution

To add job 12 to the integration and begin integrating employee position:

  1. Open Employee Mapping Table by accessing Time and Attendance via an Admin account. System Configuration > Admin > Employee Mapping Table.

  2. Navigate to the Position row in the Employee Mapping Table

  3. Remove the default value as well as the Payroll System name (if any) associated in the Position row.  You will also need to set both update drop downs to No

  4. Click Save at the bottom of the Employee Mapping Table screen.

  5. Process Integration jobs, starting with job 1, in the order of 1,2,3,4,5,12. 



Additional Information