Accrual Year End processing Error - Transfer Accrual Table Does not Exist - A subquery has returned not exactly one row

Description of Issue

Accrual Year End Processing giving error 

Error: Munis (pracceoy) Transfer accrual table (X) doesn't exist: -284 [ISAM -1]

Additional information concerning a status error of -284

A subquery has returned not exactly one row.

If you have any questions, please contact Munis Technical Support.

System Log id: XX

Context
  • Payroll 

  • Accrual Processing

  • Accrual Year End Processing 

  • Payroll 

  • Employee Maintenance

  • Employee Accruals

Cause
  • Accrual in the Error comment being transferred to was not checked as Active under Employee Accruals

  • The Accrual being transferred to was not attached in Employee Accruals. 

  • Site is using Job Based Accruals, and the Job Class on the Employee Accrual record for the Type indicated in the error does not match the Job Class of the Employee Accrual record for the Type that is being processed.

Resolution
  1. Go to Accrual Year End Processing (Payroll > Accrual Processing > Accrual Year End Processing ).

  2. Click Define.

  3. Define the Accrual Table.

  4. Enter Last Day of Accrual Year.

  5. Click Accept.

  6. Click on Output post.

  7. Check the bottom of the Screen when Error Pops up (Employee numbers will be displaying).

  8. Go To Employee Accruals (Payroll > Employee Maintenance> Employee Accruals).

  9. Click Search.

  10. Enter the Employee Number and click Accept.

  11. Navigate to the Accrual Table that is causing error.

  12. Check if the Active Check box is checked or not.

    1. If not then Click Update and Check the Active Check Box.

  13. Confirm that Job Class is the same on both tables.

    1. If not, click Update on applicable table and update Job Class.

  14. Now Process the Accrual Year End processing again.

If the Employee does not have the Accrual Type, click Add and add the Accrual Type to the employee. 

Additional Information