TCM fails at Elastic Search package deployment

Description of Issue

TCM deployment failing at Elastic Search package using Tyler Deploy

Context
  • Tyler Deploy

  • Tyler Content Manager

  • TCM

  • Elastic Search

  • SaaS

  • On-Premises

  • New Features

Cause

TCM Elastic Search Service Name variable was set as "." When Tyler Deploy tries to purge the files in the <drive_letter>:\Elastic Search\ directory, it is actually attempting to delete all files for other clients and environments as well. Since the services are running for other TCM applications, the files cannot be deleted and cause an error. 

Resolution

On-Premises Sites:

  1. From within Tyler Deploy, select Product Configurations > Tyler Content Manager 

  2. Select an environment

  3. Expand the Tyler Content Manager variables and click the Show Hidden and Show Advanced checkboxes

  4. Scroll down to the Elastic Search section and review the Service Name and Install Directory fields.

    1. Blank out the Service Name and Install Directory fields

    2. Scroll to the top and click the Save button to pull in the updated values

  5. Click Save one more time to ensure that the variables have been saved

  6. Redeploy Tyler Content Manager


SaaS Sites:

  1. Contact Tyler Systems Management Support or submit a case via the Online Support Client Portal for additional assistance.

Additional Information

Example of Tyler Deploy error within TCM deployment history logs: 'System.UnauthorizedAccessException: (5) Access is denied: [\\?\e:\Elastic Search\elasticsearch_tylercmXXXXtrainXXXX\bin\elasticsearch_tylercmXXXXtrainXXXX-x64.exe]'

Should additional assistance be required, contact Tyler Systems Management Support or submit a case via the Online Support Client Portal for additional assistance.