Supervisors Login is timing out in ESS, Request Time out



Description of Issue

Recently users who are setup as supervisors are not able to login to ESS, it will hang during login and then displays error 500 Internal Server. 

The exception logs provided the message Request Timed Out.



Context

Employee Self Service

Position Control



Cause

An unknown activity triggered one of their positions to attach to an existing position code 0, which created a hierarchy tied to any positions/employees that showed 0 for a position, which usually means they have no position code attached. A user with a Names Level >1 in ESS would pull this large hierarchy causing the login to time out.



Resolution

Please reach out to EERP Human Resources Support

Scripts will need to be run to set the position values to Blank/Null in Position Control to disconnect this hierarchy, allowing the deletion of the position code 0 record. 



Additional Information