Mass merge multiple Accounts Receivable Customers

Description of Issue

There are many different accounts receivable customer IDs (CIDs) for a single property or customer. Many different accounts receivable customer IDs need to be consolidated by joining or merging the duplicate customer numbers together.

Context
  • Accounts Receivable 
  • Property Tax Billing 
  • General Billing 
  • Civic Services 
  • Utility Billing 
  • Customers (arcstmnt)
  • Customer Merge (arcidmer)
Cause

Duplicate customer records were created either manually or through a billing import process. A duplicate customer record can be created if the spelling, punctuation, and/or address information for a customer is different in the database than in the file imported for billing. To prevent duplicate customers, make sure the spelling, punctuation, and/or address information remains consistent in import files and always search for existing customers before manually adding a new customer. 

Resolution
  1. Navigate to the Customer Merge program either by searching or using the following path: General Revenues or Property Revenues > Accounts Receivable > Setup > Customer Merge
  2. A warning appears stating: Before executing this program, completing a backup of the database is strongly recommended. If a large 'Revenue and Billing' batch or import process is currently being run, MUNIS recommends waiting for that process to complete prior to running this program.
    1. Please heed this message and take the following into consideration: 
      1. This process will merge all records (bills, receipts, parcels, personal property, motor vehicles, utility accounts, etc.) from one customer record to another customer record. If a mistake is made, there is no way to correct or reverse this process other than restoring using the most recent back up, which means any data entered after the restored back up will be lost and require manual re-entry. 
      2. If currently running a revenue bill process, bills created by that process may not be appropriately merged or the revenue bill process could be halted because the customer merge program has removed a customer record that was being utilized by the revenue bill process. 
    2. For the above reasons, it is recommended to merge customers only after immediately backing up (saving a copy of) the environment, when no other mass revenue processes are being completed, and with other users out of the system. 
  3. Select Yes to continue and No to cancel. 
  4. Click Mass Merge.  
  5. Click Define
  6. Choose one of the available methods to Search for Duplicates by. 
  7. Enter a Customer Number Range1-999999999 is recommended. 
  8. Choose to limit the merge to Customers Modified After a specific date if desired. Otherwise, leave Anytime. 
  9. Check Search for newly created duplicates (use with a recent date or cust. number) to search for duplicate Customers with a Customer Number less than rather than greater than the duplicate Customer Number if desired. Used most commonly to find duplicate customers that were recently created by an import. 
  10. Check Retain original customer record if the MERGE customer should be retained, after its associated records have been merged to the INTO customer. If this box is not selected, the MERGE customer record will be deleted from the database entirely. 
  11. Check the Include only active records in search if desired. This option is recommended. 
  12. Click Accept
  13. Click Select. 
  14. The program will identify potential duplicates based on the criteria selected during the define and display the INTO and FROM Cust No. and information for each merge.
    1. The FROM Cust No. is the customer number from which all information and records will be merged. This customer will not be associated with any records after the merge.
    2. The INTO Cust. No.  is the customer into which all information and records will be merged. This customer will retain its original records and now be linked to all the records previously associated with the MERGE/From customer.
  15. To swap the FROM Cust. No. and the INTO Cust. No. scroll to the right and check the Swap box next to the merging records. 
  16. Use the Select All and Select None as well as the Flag checkbox to the left of each merging record to indicate that they should be processed. 
  17. When all desired merges have been identified, click Process. 
  18. A loading bar will appear followed by the message Merge complete
  19. Click OK. 
  20. The name, address, and contact information as well as the associated records (bills, receipts, parcels, personal property, motor vehicles, utility accounts, etc.) have now been removed from the FROM customer and merged with the INTO customer for each merge flagged for processing. 
Additional Information
  • To merge customers individually instead of en masse, please see: Merge two Accounts Receivable Customers
  • If additional assistance is required, please contact the appropriate accounts receivable support team based on the customer.