Cashiering Menu Not Displaying in Hub SSL Error in Log



Description of Issue

External systems and page is set correctly to allow Cashiering link to be displayed in hub but it is not. Cashiering link works as expected. Hub log shows error 

Cannot retrieve the External System Version for: : Cashiering
System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. ---> System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure.

Externally the certificate for Cashiering shows as current.



Context
  • Tyler Hub

  • Tyler Cashiering

  • SSL Certificate

  • External Systems

  • LessVPN

  • AWS Hosted



Cause

Internal SSL binding in IIS on hosting server has expired, this is different from the certificate that is pushed from the firewalls when accessing cashiering externally.



Resolution

Please create a case with TSM SaaS for further assistance in the Support Portal



Additional Information