834 Report Error Detail date is null

Description of Issue

We are receiving an error when running an 834 report to send to our benefit provider Detail date is null, we are unsure how to resolve.

Context
  • Employee Benefits 834 Export
  • 834 Report
Cause

This is due to missing setup on the Employee Deduction record under the tab Insurance for the fields Enrollment Date and Coverage End Date.

Resolution
  1. To resolve, navigate to the program Employee Deductions.
    • Menu > Human Capital Management > Payroll > Employee Maintenance > Employee Deductions
  2. Click Search and find the employee shown in the error and deduction record being used in the 834.
  3. Click Insurance to open the tab to review the fields Enrollment Date and Coverage End Date.
    • We suggest setting these fields to represent the time period in which the employee is covered by the insurance.
  4. Click Update to perform your changes and click Accept to lock in your results.
  5. Navigate back to the program Employee Benefits 834 Export.
  6. To proceed, you will need to generate a new 834 record for the employee to ensure the record has the necessary information.
Additional Information

Please review the  Master Article - 834 Reporting for all related topics.