Getting Inactive Vendor Code error in Payroll

Description of Issue
  • When I run the Errors Report in the payroll, getting error S-INACTIVE VENDOR CODE or W-INACTIVE VENDOR CODE

  • Getting vendor code error when try to run Final Proof report in the payroll

Context
  • Enterprise ERP Payroll

  • Payroll Processing

  • Final Proof Report

  • Earnings and Deductions

  • Errors Report

  • Vendor Processing 

Cause

There is one or more deductions in the payroll linked to an Inactive Vendor. Inactive status will not prevent a vendor from being used. 

Resolution

Get a list of Vendors for the current payroll

  1.  From the Payroll Start and Status screen, click Vendor Processing

  2. Click Browse

Review each vendor from the list and re-activate any vendors that are Inactive

  1. Access AP Vendors (Financials > Accounts Payable > Vendor Processing > Vendors)

  2. Search for the Vendor

  3. Click Update

  4. Select Active for the Status

  5. Click Accept

If the warning is S-INACTIVE VENDOR CODE, delete and re-add the deduction code(s) in the payroll

  1. Can delete and re-add the deduction(s) for each employee on the Withholding tab in the Earnings and Deductions screen

  2. Or, use the Global option in the Earnings and Deductions screen to globally delete and re-add the deduction(s).  How to globally delete and add a deduction in payroll

Additional Information

Vendors are linked to the deductions on the Deduction and Benefit Master screen (Payroll > Payroll Setup > Deduction and Benefit Master).

A change was made under following work tickets to include the Deduction code that is linked to the inactive vendor and to mark this error as a Warning rather than Serious error. If it is a Warning you do not need to delete and re-add.

MUN-480634-2021.11.0.884

MUN-480632-2021.12.0.362

NOTE - Tickets listed above caused an issue with Employee Update displaying error, Serious Errors in Data. Use Error when Processing Employee Update - Serious Errors in DataÂ