Department Notify - Wfnxtpe3 - An error occurred inserting a pending notification for Workflow Assistant to retrieve for approver Status -268

Description of Issue

[wfwsgene] Wfnxtpe3 - An error occurred inserting a pending notification for Workflow Assistant to retrieve for approver (XXXX). Status= -268

Context
  • Central Budget Entry

  • Next Year Budget Entry

  • Department Notify

Cause

A pending notification has already been submitted for the User and Department selected.

The recipient currently has the maximum number of pending notifications.

Resolution

Work ticket MUN-477160 is open with development to introduce intuitive error messages to outline these scenarios.

To validate this scenario, have the expected recipient review their pending notifications, if they do not have a BLV notification, they have likely exceeded the maximum number of Pending Notifications. In that instance, the steps below can be followed.

To acknowledge all pending notifications for a user:

System Administration > Security > User Attributes

  1. Search the User ID mentioned in the error message.

  2. Select the Workflow Detail tab

  3. Select Mass Acknowledge Notifications

  4. Click Select, then Select All, and Accept.

  5. Click Execute.

  6. In the pop-up window, click Yes.

  7. In the Successfully Acknowledged Notifications pop-up window, click OK.

  8. Close and reopen the program where the error occurred prior to releasing the transaction again

If the error persists, the user listed in the error message may be forwarding their approvals to a different user.  Notifications for this user will also need to be acknowledged. 

  1. Search the User ID mentioned in the error message.

  2. Select the Workflow Detail tab

  3. If there is a user id listed in the field next to Approvals will be forwarded to approver , Search for this user in the User ID field back at the top of the screen and repeat steps 3-8 from above

To dismiss certain notifications, simply have the user being notified go to the location where they get notifications (email, dashboard, workflow assistance) and have them dismiss the pending notification

Additional Information