Parcel not found message in Municipal Lien Certificate
Description of Issue
Receiving the message Parcel not found. in the Municipal Lien Certificate (MLC) program.Â
Context
- Property Tax Billing
- Municipal Lien Certificate (tmalienc)
- MLCÂ
- Parcels (txremast)
Cause
There are multiple factors that would lead to this message being received. Some of them include:Â
- The parcel ID was entered incorrectly or with delimiters and should not have been.Â
- The parcel has no bills in the specified Years to include.Â
Resolution
- Verify that the Parcel ID was entered correctly. If it was entered with delimiters, special characters like . or -, then attempt entering it without the delimiters.Â
- If the messages persists, troubleshoot further with steps 3-5.Â
- If the Parcel ID is correct, verify that there are bills for the parcel within the three Years to include specified in the define.Â
- This can be done by navigating to the Bill Inquiry program: General or Property Revenues > Payment Processing > Bill Inquiry
- Select Parcel.Â
- Enter the Parcel IDÂ that the MLC is being generated for.Â
- Click Accept.Â
- Bills will need to return within at least one of the three Years to include entered on the MLC define.Â
- If no bills can be found for the parcel within the specified three Years to include, then update the Years to include to contain at least one year that the parcel received a bill for.Â
- After updating the Years to include to a range within which the parcel was billed, the message should clear and the MLC can be processed as usual.Â
Additional Information
- If the Years to include field is not defaulting to the current year, please see: How to change the default current year in the Municipal Lien Certificate program
- If additional assistance is required, please contact Tax Support for the appropriate region.Â