Parcel not found message in Municipal Lien Certificate

Description of Issue

Receiving the message Parcel not found. in the Municipal Lien Certificate (MLC) program. 

Context
  • Property Tax Billing
  • Municipal Lien Certificate (tmalienc)
  • MLC 
  • Parcels (txremast)
Cause

There are multiple factors that would lead to this message being received. Some of them include: 

  • The parcel ID was entered incorrectly or with delimiters and should not have been. 
  • The parcel has no bills in the specified Years to include. 
Resolution
  1. Verify that the Parcel ID was entered correctly. If it was entered with delimiters, special characters like . or -, then attempt entering it without the delimiters. 
  2. If the messages persists, troubleshoot further with steps 3-5. 
  3. If the Parcel ID is correct, verify that there are bills for the parcel within the three Years to include specified in the define. 
    1. This can be done by navigating to the Bill Inquiry program: General or Property Revenues > Payment Processing > Bill Inquiry
    2. Select Parcel. 
    3. Enter the Parcel ID that the MLC is being generated for. 
    4. Click Accept. 
    5. Bills will need to return within at least one of the three Years to include entered on the MLC define. 
  4. If no bills can be found for the parcel within the specified three Years to include, then update the Years to include to contain at least one year that the parcel received a bill for. 
  5. After updating the Years to include to a range within which the parcel was billed, the message should clear and the MLC can be processed as usual. 
Additional Information