Verify Postback URL for Citizen Self Service

Description of Issue

User receives Gateway authorization has not been received error while using Web Payments Import to import web payments. 

Context
  • Munis
  • Citizen Self Service
  • Web Payments Import
  • All versions of Munis
Cause
  • The Postback URL located in MSSHosting may be incorrect.
  • The payment service provider (i.e. Paymentus, Bridgepay, etc.) may not have the correct Postback URL.
Resolution
  1. Access MSSHosting 
    1. MSSHosting is a separate page from CSS. Please ensure you are using the correct credentials for MSSHosting.
    2. For sites using Tyler Deploy, the MSSHosting URL may be found in:
      1. Product Configurations > Munis ERP > Environment > Munis ERP > IIS Info > CSS Hosting URL

  2. Click Client Configuration
  3. Click Payment Services
  4. Click Change (blue link)
  5. Click Continue
  6. Locate Recommended silent postback URL which will appear similar to the following:
    1. Recommended silent postback URL: https://[YOUR CLIENT WEB SITE ROOT URL]/PaymentConfirmation.ashx?svc=0&client=1

    2. The important pieces here are what go into the brackets and the svc= and client= numbers
  7. Navigate to your Citizen Self Service page
  8. Click Home
    1. This URL should be included in the Postback URL, but should exclude /default.aspx
  9. Ensure that the CSS root URL is what is included in the Postback URL
    1. Example: https://townofmunis.munisselfservice.com/css/default.aspx is the full CSS URL

      The postback URL should look like:  

      https://townofmunis.munisselfservice.com/css/PaymentConfirmation.ashx?svc=0&client=1

  10. Ensure that the payment provider has the correct Postback URL.
    1. If your Payment Service requires that you provide them with the Postback URL, please contact them and request that they provide you with what they currently have.
  11. Verify URL is set up correctly in MSSHosting if required 
    1. Not all Payment Services require this. 
Additional Information