Master Article - Web Payments Import Missing Gateway Confirmation and Authorization Numbers

Description of Issue
  • Unable to import payments in Web Payments Import
  • Web Payments missing Gateway Authorization/Confirmation numbers
  • When processing Web Payments Import for online payments the error Gateway authorization has not been received was returned for some payments
Context
  • Web Payments Import
  • Citizen Self Service
  • Web Payments
  • Postback
Cause

There are a variety of reasons why web payments would be missing Gateway Authorization/Confirmation numbers. Please see the Additional Information panel Before using the troubleshooting tree steps listed below.

Resolution
  1. Check Postback URL:
    1. Verify Postback URL for Citizen Self Service
  2. Check WSUSER permissions in Munis. See article below for steps and relevant permissions.
    1. Update WSUSER Permissions to Import Web Payments
  3. Check Web server logs to ensure vendor is attempting postback
    1. This step should be completed by Munis Support or a member of the on-site IT Staff
      1. Access the Web server
      2. In File Explorer, navigate to: C:\inetpub\logs\LogFiles\W3SVC#
        1. To find the right W3SVC number, check MSS Hosting Client Configuration > Web site instance ID. That's the number you put after W3SVC

      3. Open a log file from a date that corresponds to known payment activity
      4. Search (CTRL+F) the file for /paymentconfirmation.ashx
      5. If /paymentconfirmation.ashx is not found in the log file, the vendor is either not attempting postback, or there is a firewall blockage.
      6. It is critical that the postback include the full svc=X&client=X from the postback URL. If any part of this value is missing from the /paymentconfirmation.ashx in the log file, then postback will fail. In prior cases, the ampersand has been missing, so the postback read svc=Xclient=X instead of the correct value, svc=X&client=X.
  4. Check firewalls
    1. For On-Premises: IT will need to make sure the payment vendor is whitelisted.
    2. For Hosted/SaaS: Munis has made sure that all known vendors have already been whitelisted.
    3. Payment vendor may need to make changes to their firewall to permit inbound connections.
  5. Confirm that the correct Confirmation Numbers are being provided with the postback: 
    1. Could not select payment header arwebpmh error in System Log for the arwshdlr program
  6. Confirm that an IO Exception: Stream closed error is not being received: CSS returning multiple IOException
Additional Information
  • Customer may not have completed the payment. Payments appear in Web Payments Import > Maint Pmts but will not receive Gateway Authorization/Confirmation numbers unless the payment is fully processed/confirmed by payment service provider.
  • If the payment processor/bank confirms that the payment was processed, the Web Payment may be manually authorized so it can be imported.
  • If all payments failed to get Gateway Authorization/Confirmation numbers for a period of time, but have since begun working again, this may be attributed to a temporary networking issue. Please see above for steps to manually authorize payments if needed.