Overtime policy does not trigger as expected



Description of Issue

After creating overtime policies, using workgroup as the defined selection criteria, the overtime policy does not trigger when time is entered in Timesheet Entry which exceeds defined thresholds of OT Policy



Context
  • Time & Attendance

  • OT Policies

  • Master File Management

  • Employees



Cause

The employee in question does not have the correct work group assignment, so is not included when the overtime policy thresholds are exceeded when entering time.



Resolution

Update the workgroup assignment in the Employee Profile using the edit for history option

  1. Navigate to System Admin > Master File Management > Employees 

  2. Click clock icon to edit for history next to an employee that has an incorrectly assigned workgroup

  3. Define the Save Properties panel at the bottom of the General Info tab

  4. Select Save for whole history and override subsequent changes starting at radial button

  5. Select the earliest date available

    1. Do not click Save For Specified Past Pay Period yet

    2. Clicking this too early will disable the save functionality

  6. Navigate to Pay Properties tab

  7. Change the default workgroup to the appropriate selection

  8. Now, click Save For Specified Past Pay Period 



Additional Information

 In order for the save for history to appropriately function, both parts must be defined before saving - the time period for which you want to save as well as the data that needs to be adjusted in history. Without having both defined prior to saving, you may lose the ability to overwrite the piece of historical data desired.