Badge not Found



Description of Issue

Badge not found displays on time clock after badge is presented or badge number keyed in



Context
  • ExecuTime

  • Time + Attendance

  • ET

  • TA

  • Time clock

  • TouchTime

  • Proximity Badge



Cause

The badge number does not exist in the badge.cfg file on the time clock

  • The time clock didnt receive its file update. The primary reason for this is network related. Intermittent connectivity causes the transfer to fail with the clock not taking another update until the next job update cycle.

  • The time clocks profile has been defined with a Work Group. Work Groups act as a filter when creating the badge file and limit the values written to the badge file. The badge file will only contain employees that are in the specified Work Group.



Resolution
  • Manually upload \flashdisk\badge.cfg

  • Re-run System Admin\Scheduled System Jobs\Timeclock configuring job in primary application



Additional Information

Badge swipe/Key entry – To speed up the verification process on a Timeclock, a badge file (\flashdisk\badge.cfg) is created locally on the app server and then uploaded to the clocks via the Timeclock Configuring job in T&A. This is a simple text file that contains the badge number and employee name. Again, the purpose for this is performance. Upon badge swipe, the clock must convert the presented media (e.g., Proximity, Barcode, badge, key fob) into an application-oriented value. Badges, when scanned, return binary values and this must be converted into decimal (read processing power and seconds) which then can be compared to the badge number stored in the application. With the converted badge number in hand (in memory, on the clock), instead of making an expensive API call (more seconds) the clock will read its local badge.cfg file and scan it for a valid badge number. Pass or fail.