How to clear the RabbitMQ log



Description of Issue

The C:\ drive is almost out or is out of space



Context
  • Tyler Workflow

  • Time and Attendance

  • RabbitMQ



Cause

RabbitMQ log can grow to GBs in size and take up space on the drive



Resolution
  1. Open an elevated Windows PowerShell

  2. Right click and Run as Administrator

  3. Open File Explorer

  4. Navigate to C:\Program Files\Tyler Technologies\RabbitMQ\log

    1. By default, this is the C:\ drive but can also be located on other drives. 

  5. Note the name of the log file.

    1. Log file name starts with Rabbit and ends with the name of the server.

      1. For example: rabbit@servername.log

  6. Copy the path by placing the cursor in the address bar, right click and select copy

  7. Back in the Windows PowerShell prompt, type cd and press CTRL+V to paste the path to the log file. 

    1. Should show as cd "C:\Program Files\Tyler Technologies\RabbitMQ\log"

  8. Press ENTER

  9. Type Clear-Content nameofrabbitlog

    1. For example: Clear-Content rabbit@servername.log

  10. Press ENTER

  11. Log file has now shrunk in size

    1. No service restart necessary



Additional Information

RabbitMQ is a critical piece to the functionality of Tyler WorkflowÂ