Cashiering Database Has Grown Due to Log Messages Table

Description of Issue

Our Cashiering database size has grown exponentially. After reviewing the database Disk Usage by Top Table report (How to identify large tables in database), it was found that the dbo.LogMessages table is very large.

Context
  • Cashiering
  • Logging
  • Database size
Cause

Cashiering logs are not being purged because a retention schedule is not set. Logging levels may also be set to Debug which logs all activity in Cashiering and accumulates quickly when not being purged.

Resolution

2021+

  1. Log into the Cashiering web-based client with an admin account
  2. From the left side menu, click Administration
  3. Click Settings
  4. Click the General tab
  5. Under Logging, adjust levels as desired
    1. Error is the recommended logging level
    2. Debug logs all activity and is typically used short term for troubleshooting purposes
  6. For the logs to purge, you must set BOTH Maintain logs for and Clear logs at
  7. Click Save

2019.1 and 2019.3

  1. Log into the desktop client with an admin account
  2. In the ribbon, click Setup, then click Settings
  3. Click the Logging tab and set desired logging level
    1. Error is the recommended logging level
    2. Debug logs all activity and is typically used short term for troubleshooting purposes
  4. For the logs to purge, you must set BOTH Days to maintain logs and Time to clear logs
  5. Click Save
Additional Information
  • If a retention schedule is set correctly, the logs are not purging, and on version 2021.8 or lower, please see: Cashiering Not Purging Log Files
  • If the database size has grown extremely large and is taking too much disk space, TSM can possibly release the unused space back to the OS after the logs have been cleared. Please contact Tyler Systems Management Support or log a case via the Online Support Client Portal
  • Cashiering Logging Levels