Using IDTECH MiniMagII with PayGuardian for Cashiering



Description of Issue

Setting up the IDTECH MiniMagII IDRE-335133B with PayGuardian to use with Cashiering



Context
  • Cashiering

  • PayGuardian

  • IDTECH MiniMagII



Cause

Need to configure the IDTECH MiniMagII credit card swipe to work with BridgePay/PayGuardian



Resolution

Please note: The IDTECH MiniMagII IDRE-335133B only works with BridgePay and it MUST be acquired through BridgePay to be properly encrypted.

  1. Obtain the Cashiering Hardware Drivers

  2. Extract the ManualHardwareDriversV3 directory from the .zip package to a temp folder on the PC (i.e. C:\temp)

  3. Open the <TEMPDIR>\ManualHardwareDriversV3\ IDTechMSR\80096802-004 SecureMag_USBHID_OPOS_Driver_v3.12_A\SecureMag_USBHID_OPOS folder and launch setup.exe

  4. Accept all default values and install the software

    1. Note: Do NOT reboot when prompted

  5. From within Cashiering, select the credit card tender and click Complete. You will then be redirected to PayGaurdian to swipe the credit card.



Additional Information
  • When using the IDTECH MiniMagII device with PayGuardian, the device should not be setup as an active device in the Cashiering Hardware Console. All communication between the IDTECH MiniMagII device, Cashiering, and PayGuardian is done through the device drivers installed upon setup.

  • If the IDTECH MiniMagII is setup in the Hardware Console it will result in the Cashiering Hardware Health to show the error One or more device errors. Unable to initialize magnetic swipe reader. The interaction between Cashiering and PayGuardian will still work but it will cause some confusion seeing the hardware error.

    • Remove the IDTECH MiniMagII from the Hardware Console to clear the Hardware Health error.

  • Help Central - Hardware Matrixes

  • Tyler Community - Cashiering Hardware Matrixes