Failed to encrypt the value on Cashiering Credit Card Transactions



Description of Issue

After clicking Complete in Cashiering for a Credit Card tender, nothing happens. Cashiering logs show the error Failed to encrypt the value.



Context
  • Cashiering

  • Payments POS

  • Paymentech

  • ROAM

  • Bridgepay

  • PayGuardian

  • Credit Card



Cause

The credentials calling to the credit card processor need to be re-entered. This issue can occur after an update or server migration, even if the credentials have not changed. 



Resolution
  1. Navigate to Administration>Credit Card Processors.

  2. Edit the Credit Card Processor tied to your Credit Card Tender Type.

  3. Bridgepay: Re-Enter PayGuardian UserID and PayGuardian Password. 

  4. Payments: Re-Enter Client ID and Client Key.

  5. Save. 



Additional Information

If issues continue after making these changes, try typing the PayGuardian Password/Client Key by hand rather than copy-pasting the information.Â