Error Running Tyler Cashiering Reports Following Password Change



Description of Issue

Following a password change all Tyler Cashiering Reports are failing with the error:

Unable to generate the report with the current criteria -or- Error while executing report. See the logs for more detail

System logs show the following:

Exception (System Exception): The HTTP request is unauthorized with client authentication scheme 'Ntlm'. The authentication header received from the server was 'NTLM'. Inner Exception (System Exception): The remote server returned an error: (401) Unauthorized.



Context
  • Tyler Cashiering

  • Password Reset

  • Password Update

  • Reports

  • On-Prem

  • tylerservice

  • Service Account



Cause

Tyler Cashiering versions 2018.1 and above use service account credentials (such as tylerservice) stored in an encrypted AppSettings.config file to make a connection to SSRS for reports. 



Resolution

Versions not deployed through Tyler Deploy


Versions deployed through Tyler Deploy 

  • Option 1: Manual workaround. Requires restarting Cashiering application pools, making Cashiering unavailable momentarily

  • Option 2: Update password in Tyler Deploy variables and redeploy. Cashiering will be unavailable for the length of the redeployment

    • Changes can be made in Tyler Deploy by an administrator with Deploy\Configure permissions

    • - OR - Contact Tyler Systems Management Support or log a case via the Online Support Client Portal


Update password in Tyler Deploy variables

  1. Log into Tyler Deploy and select the applicable client tenant

  2. Navigate to Product Configurations > Tyler Cashiering Server

  3. Select the applicable environment from the drop down

  4. Expand Tyler Cashiering Server

  5. Scroll down to SSRS

  6. Update the password for SSRS Server Account Password

  7. Scroll back up and click Save

  8. Click Go to Deployment

  9. Force redeploy Cashiering on the same version

    1. Please note: Cashiering will be unavailable for use during the redeployment

  10. Repeat for all Cashiering environments



Additional Information