Batches of Receipts missing GL Allocation

Description of Issue

Every receipt in a batch that should have a GL Allocation is missing a GL Allocation. 

Context
  • Accounts Receivable
  • Payment Entry (arbilinq)
  • Cashiering
  • Tyler Payments
Cause

This issue can have multiple causes. Known causes include: the AR/GL integration was turned off or the receipt is a Reversal or Payment Redistribution. 

Resolution
  • Whether or not certain Accounts Receivable activity impacts the General Ledger is controlled by a series of settings. Please check the Audits in these programs to determine if the GL was accidentally or intentionally disabled, causing this issue: 
  • If the Activity of the receipts is Payment, ensure that the Reversal Status is not Reversal (indicating that this receipt is the reversal of another payment). It is expected for reversals of another payment in the batch to have no GL Allocation. 
  • If the Activity of the receipts is Payment Redistribution, then review what was redistributed. In instances where payments are being redistributed on the same Charge Code or to Charge Codes that use the same GL Accounts, no GL Allocation is expected because no additional money is being received/needs to be posted. The redistribution is simply re-allocating amounts already received on the Bill so that no line or installment is under or over paid. Because these amounts have already been posted to the GL, an additional Journal Entry is unneeded.
  • There have been confirmed instances of batches losing their GL Allocations prior to posting in version 2024.1. To correct this, make sure that PROD and a Non-PROD environment (TEST or TRAIN) are on version 2024.1.0.732 or higher. Then, refresh the Non-PROD environment with data from PROD and post the batches that are missing GL Allocation. After posting, the GL Allocation should be restored. Confirm that the GL posting was correct in the Non-PROD and then post the batches in PROD. 
Additional Information

In instances where a cause is indeterminable, this issue seems to be intermittent, impacting batches one day but not the next. Affected Batches may have hundreds of Receipts that are all missing GL Allocation information. This problem occurs regardless of Billing Category and Receipt Source.