Hours missing after employee changed shifts
Description of Issue
Client reported a user was moving from one shift to another shift and the hours for the last day of the original shift were deleted.
Context
ExecuTime
Time & Attendance
Advanced Scheduling
Shift Maintenance
Cause
The issue was the effective end date of the shift was set to the incorrect date. The end date was set to the last day of the shift instead of being set on the day the new shift starts.
Example - Shift A has a final shift on the 11th day. The shift's effective date was set to the 11th which deleted the shift on the 11th. By setting the effective end date to the 12th and the new shift to start on the 12 the old shift will not delete the final day worked.
Resolution
Additional Information
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