TPAR Collections Export Error returned from BatchManager.createBatch

Description of Issue

Attempting to run the Collections Export (Service) results in the error Error exporting transaction data to Munis. Exception has been thrown by the target of the invocation. MUERROR: Error returned from BatchManager.createBatch. [System log Id: xxxxx]

EERP System Logs state that year/per are outside of users permitted range.

Context
  • TPAR

  • Parks & Rec

  • Tyler Parks and Recreation

  • Enterprise ERP

  • Collections Export

Cause

The web service Access ID needs permission to create batches in the current fiscal year and period.

Resolution

On Prem Clients

  1. Navigate to Enterprise ERP > System Administration > User Attributes.

  2. Search.

  3. Type wsuser into the User ID field.

  4. Accept.

  5. Highlight their Role in the Role window and select Edit Role.

  6. Select General Ledger.

  7. Update.

  8. Set Allow transactions in periods prior to the default to at least 1.

  9. Set Allow transactions in periods beyond the default to at least 1.

  10. In the GL Year Access tab, select all three options.

  11. Accept.

SaaS Clients

  1. In Parks & Rec, navigate to Administration > System Setup > Integration Settings.

  2. Expand Collections Export.

  3. Copy the Access ID.

  4. In Enterprise ERP, navigate to Enterprise ERP > System Administration > User Attributes.

  5. Search.

  6. Paste the Access ID into the User ID field.

  7. Accept.

  8. Highlight their Role in the Role window and select Edit Role.

  9. Select General Ledger.

  10. Update.

  11. Set Allow transactions in periods prior to the default to at least 1.

  12. Set Allow transactions in periods beyond the default to at least 1.

  13. In the GL Year Access tab, select all three options.

  14. Accept.

Additional Information

If the Access ID has multiple roles attributed to it, any Role can be used to grant permissions. The system will automatically use the Role with the most permissions.

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