TPAR Cashiering - Cannot read properties of null

Description of Issue

When redirecting to Cashiering to complete a TPAR transaction, the error message Cannot read properties of null generates when attempting to complete the transaction.

Context
  • TPAR

  • Parks & Rec

  • Tyler Parks and Recreation

  • Cashiering

Cause

Parks is redirecting to the incorrect payment type, causing all transactions to flow incorrectly.

Resolution

Cashiering

  1. Navigate to Administration > Payment Type Settings.

  2. Find the Parks Invoice Payment Type and select Edit.

  3. Highlight and copy the Cashiering Reference ID field.

Parks

  1. Navigate to Administration > System Setup > Integration Settings.

  2. Open Cashiering Settings.

  3. Paste the Cashiering Reference ID into the Cashiering Reference ID field.

  4. Save.

Additional Information

Â