Employee Pay Import Error-Pay Basis P is not valid

Description of Issue

I am using the Employee Import program to update locations on retired employees. I am receiving an error on my Import proof: "Pay Basis 'P' is not valid".

Context
  • Payroll
  • Employee Job/Salary
  • Employee Import
Cause

Pay Basis 'P' came over from an older version of Munis, but is not used any longer.

Resolution
Need to delete all historical instances of the pay code, then re-add with a valid pay Basis. This can be done manually in Job/Salary, or you can use How to Create a Custom Template for Employee Imports to create a new Delete import template to delete the historical records, and then run a second import to add the new ones.  Once that has been completed, proceed with your location update import. 
Additional Information