Munis web payment amount differs from the amount charged by Paymentus

Description of Issue

The amount recorded by the Munis web payment is different than the amount charged to the customer by Paymentus

Context
  • Munis
  • Citizen Self Service
  • CSS
  • Paymentus
Cause

The payment field in Paymentus is set to allow customers to modify the amount. If changed, Paymentus can charge an amount that differs than the amount Munis applied to the bill(s).

Resolution

Work with Paymentus Support to modify the payment field to be read only to ensure customers can not change the amount.

Additional Information

Paymentus Customer Care:

PH: 800-420-1663

Email: customercare@paymentus.com