Email Unable to Send Authentication failed nested exception is javax mail AuthenticationFailedException failed to connect no password specified - version 2019 and prior

Description of Issue

After entering in SMTP information for ExecuTime, test emails aren't sending. Received the following error message on the Communication tab: Email Unable to Send: Authentication failed; nested exception is javax.mail.AuthenticationFailedException: failed to connect, no password specified?

Context
  • ET
  • ExecuTime
  • SMTP
  • Emails
  • v2019
  • v2018
Cause

A java mail property that is used to determine how to authenticate to an SMTP server is set to true instead of false.

Resolution
  1. The Java Mail Properties field can be by navigating to System Admin > UI Environment Flags > Admin
    • Can only be accessed with the admin account
  2. On this page, look for the Java Mail Properties field
  3. Modify the mail.smtp.auth flag from true to false
    1. for example: mail.smtp.auth=false
  4. Select Save
  5. Test sending emails to verify that you are no longer receiving the error message and that you receive Email Sent Successfully
    1. If you receive the same error, verify that you entered the correct value for the java mail property.
    2. If you receive a new error, please create a case with the ExecuTime TSM Team
Additional Information

This error message means that the SMTP Server doesn't require credentials to authenticate to it. The username and password fields would be blank and by changing the authentication flag to false, will resolve the error received. 

For versions v2020 or higher, refer to Email Unable to Send Authentication failed nested exception is javax.mail.AuthenticationFailedException failed to connect, no password specified