Cannot add role to workflow business rule
Description of Issue
- Specific role is not available when user is adding a new role-based workflow business rule
- Can see some roles but not all roles when adding role-based workflow business rule
- Error: The role ID entered contains no user ID's flagged as approvers with active accounts. Please choose another role.
Context
- Munis
- Workflow
- Roles and permissions
Cause
No workflow approvers currently hold a specific role
Resolution
- In order for a role to be usable within a role-based workflow business rule, the role must be held by a user that is a workflow approver
- To make a user a workflow approver, access System Administration > Security > User Attributes (find the user in question) > Workflow Detail > Promote
Additional Information
Please reach out to Munis Software Support with any follow-up questions