Unable to update expense template due to unapproved claims


Description of Issue

Need to update expense template with new codes/rates but errors are received: 

  • Unapproved claims for this template exist.  A new code for this template cannot be added until all claims for the template have been approved for reimbursed/closed.
  • Claims with this expense exist There are XXXX claim(s) that contain this expense. Updates to certain fields may be disallowed to prevent the corruption of claims that are being processed.
Context

Employee Expense

Cause

Certain template field updates are not allowed when estimated or unapproved claims exist that use that template

Resolution
  • Before new codes can be added to a template, all claims using that template need to be in status of 18 - Actual, Approved, 20 - Reimbursed/Closed, or 30 - Reimbursed with Overpayment
  • If template changes need to happen before all claims are closed:
    1. Set the status of the current template to Inactive, which will prevent additional claims from being processed for that template, but will allow processing for existing claims to continue
    2. Use the Duplicate function to create a copy of the template where you can remove the old code and add the new one
Additional Information