Entries are duplicating in ESS Time Entry



Description of Issue
  • Entries are duplicating in ESS Time Entry
  • The Supervisor is seeing duplicate entries in ESS Time Entry
Context
  • Munis
  • Employee Self Service (ESS)
  • Time Sheets
  • Time Entry
Cause
  • The user experiencing the duplication as an incorrect Munis User ID attached to their account
  • Duplicate Workflow Business Rules exist for the same step
Resolution
  • To review for the incorrect Munis User ID
    1. Navigate to User Administration in ESS
    2. Search and select Edit on the user account
    3. Review for the Munis User ID 
      • User Attributes in Munis
      • This is determined by Employee ID assigned in both ESS and Munis
    4. Remove the incorrect Munis User ID and select Update to save


  • To review for the duplicate Workflow Business Rule
    1. Navigate in Munis to Workflow Business Rules
      • Menu → Human Capital Management → Human Resources → Personnel Setup → Human Resources Workflow Administration → Business Rules
    2. Select Search and define EST for ESS Time Entry in the field for Process
    3. To identify a duplicate business rule you can navigate to the program Employee Pending Time Entry
      • Menu → Human Capital Management → Payroll → Employee Maintenance → Employee Pending Time Entry
    4. Select Search and define the Employee Number field
    5. Locate any example record and select the Audit tab
    6. Select the Approvers option to expand the workflow audit
    7. Review for the step where you see the approvers name duplicated
    8. Click on the approvers name to expand that workflow business rule detail
    9. Review for the Rule ID value
    10. Use the Business Rule ID field in the Business Rule program to find an exact match
    11. One the duplicates have been determined, select Delete to remove one of the rules
    12. Once deleted the records will need to be released to reset their workflow setup
    13. Navigate to Employee Pending Time Entry and preform another Search
    14. Navigate to the Audit tab and define in the field Workflow Status the value X - In Progress to retrieve all current records 
    15. Select the option Mass Release to reset these records to the new workflow setup
Additional Information
  • Please reach out to Munis Human Resources Support with any additional questions