How to Run or Schedule an Update in Tyler Deploy for Cashiering

Description of Issue

Cashiering environment needs to be updated to a newer release 

Context
  • Update
  • Upgrade
  • Tyler Cashiering update
  • Release lifecycle
Cause

Clients have the ability to schedule Cashiering updates on their own through Tyler Deploy, or they can make a request for Support to apply the updates.

Resolution

Prior to Applying Updates

  • Tyler recommends updating to the latest generally available version of our software that is compatible for your needs and integrating products.
  • Always review major integrating products compatibility matrixes prior to updating to verify version compatibility
  • Always thoroughly test upgrades in a Non-Production environment before upgrading Production
  • Review hardware matrixes for device compatibility
  • Please see Tyler Cashiering Upgrades for major version considerations
  • Close all open batches prior to applying updates


Running or Scheduling the Update

  1. Navigate to https://tylerdeploy.com/
  2. In the left navigation menu, under Deployment, expand Product Deployments and select Tyler Cashiering Server
  3. Select Environment
  4. In the Product Release tab click on the Channel drop-down to select the major version of your Tyler Cashiering (i.e 2021.1, 2021.2, etc
    1. Please double-check your major version before committing to the update. Selecting the incorrect major version could cause undesired changes. 
  5. Click on the Release dropdown and select the desired release version (i.e 2021.1.8.0, 2021.1.8.1, 2021.1.8.2, etc)
    1. It is optional to have the Check Prereqs box checked. If prereqs are missing on any of the target servers, the deployment will not run.
      1. Prereqs can be checked/installed in advance: Install Server Prerequisites in Tyler Deploy
    2. You do not need to have the Force Redeployment box checked. This is used by support for troubleshooting purposes.
  6. Use the now-later toggle button if you would like to schedule the update for a later time or leave off to start immediately
  7. Click Start to begin update or Schedule if you are scheduling to run at a later time
  8. After the update is complete, any workstations that have the Cashiering client and/or Hardware Console installed will need to be replaced with the new version
    1.  Please note, leftover installation files from previous versions may cause hardware conflicts