PM recurrence patterns are ignoring end date option when triggering new work orders



Description of Issue

Preventive maintenance (PM) recurrence patterns are being triggered from creation date of last work order instead of end date when the setup record is set to the work order end date option



Context

EAM



Cause

By design, recurrence pattern PM's cannot be triggered from a work order end date



Resolution

By design, PM recurrence patterns trigger off of creation date of last work order.  If no prior work order exists, the specified trigger date will be used instead.



Additional Information

Work ticket MUN-442152 will be removing the end date option from Asset Registry for recurrence pattern PM's